Skip to main content

IT News

Firefox no longer compatible with MAP or Banner 8

If you are a regular user of the Firefox browser, you may be unable to access MAP (Mountaineer Administrative Processes) and Banner 8. Only Internet Explorer (IE11) will support these systems. The latest update of Firefox drops support of Java, rendering that browser incompatible with systems that rely on Java plug-ins. 

Firefox is releasing this version as a rolling update, meaning different people receive it at different times. You may have already encountered this issue. If not, you will in the coming weeks. Firefox has planned to drop Java support for some time, and Google Chrome has already done so. All WVU employees should use the latest version of both Firefox and Chrome to ensure you have the latest security updates.

Contact Service Desk

Phone: (304) 293-4444 | 1 (877) 327-9260
Email: ITShelp@mail.wvu.edu

Get Help