Skip to main content

IT News

Until security issue is resolved, faculty may only sync i>Clicker2 while on campus

Starting Monday, Nov. 24 and for the remainder of the fall semester, faculty will be able to sync i>Clicker2 software from on-campus locations only. Users who try to sync software from off-campus locations will get an error message, “Validation Error: There was problem validating the information provided. Please check your entries and try again.”

A vulnerability was recently discovered in i>Clicker2 version 6.4.1 and earlier versions. That means the privacy and security of transmissions can no longer be guaranteed.

Faculty using v6.4.1 and earlier versions will need to upgrade their software to iClicker2 version 6.4.2 afterthe fall semester ends.

The new V6.4.2 software will be available on Dec. 29 at http://it.wvu.edu/services/training/iclicker under “Software Downloads.” All faculty should upgrade to this version before the start of the spring semester. Afterward, users will be able to sync from both on- and off-campus locations.

Please direct questions or concerns to the ITS Service Desk at (304) 293-4444 or email ITSHelp@mail.wvu.edu.